How to Configure Cisco 881 Series Router with Cable modem and static IP

This tutorial will show how to configure Cisco 881 Series Router with Cable modem in bridged mode and static IP address. It will work with any model that has Fast Ethernet WAN interface. Simply what it means your WAN interface connects to Cable Modem with Regular Ethernet cat 5e or 6 patch cable.
The particular Cisco 881 model comes with following interfaces:

  • WAN Interface: 10/100-Mpbs Fast Ethernet
  • 4 LAN Interfaces: 4-port 10/100-Mbps managed switch
  • In this example your company received static public IP address and we will use NAT to forward packets to internal computers. In our example WEB server is located on the internal network and all requests from outside NAT-ed to this server for http requests.
    This setup will only work if you have static IP address from your ISP , if you use DHCP it will only work until your DHCP lease is renewed and then configuration will be broken.

    When you first boot up your Cisco router, some basic configuration has already been performed. All of the LAN and WAN interfaces have been created, console and vty ports are configured, and the inside interface for Network Address Translation (NAT) has been assigned.

    Step 1 . Get public static IP address from your ISP .

    In our example following IP address was given by provider.

  • Ip address 9.10.10.10
  • subnet mask = 255.255.255.0
  • default gateway = 9.10.10.1
  • Our internal network will have simple setup of private 192.168.0.0/24 subnet

    WEB server will run on 192.168.0.3 ip addres

    Step 2 . Configure Command-line Access .

    We will start with configuring access control to router.

    Router#conf t
    
    Router(config)#line console 0
    

    Specify a unique password for the console terminal line.

    Router(config)#password yourpassword
    
    Router(config-line)# login
    

    This example shows a timeout of 5 minutes and 30 seconds. Entering a timeout of 0 0 specifies never to time out.

    Router(config-line)# exec-timeout 5 30
    

    Specify a virtual terminal for remote console access

    Router(config-line)# line vty 0 4
    
    Router(config-line)# password yourpassword
    
    Router(config-line)# login
    
    Router(config-line)# end
    

    Step 3 . Configure Global Parameters .

    Router> enable
    
    Router# configure terminal
    
    Router(config)#
    

    Specify the name for the router.

    Router(config)# hostname Routername
    

    Specify an encrypted password to prevent unauthorized access to the router

    Router(config)# enable secret yourpassword
    

    Disable the router from translating unfamiliar words (typos) into IP addresses.

    Router(config)# no ip domain-lookup
    

    Step 4 . Configure WAN Interface.

    Configure your WAN interface with IP address provided by ISP

    Router(config)# interface fastethernet 4
    
    Router(config-if)# ip address 9.10.10.10 255.255.255.0
    
    Router(config-if)# no shutdown
    
    Router(config-if)# exit
    

    Step 5 . Configure Vlan1 .

    Configure ip address for Vlan1 which also will be default gateway for Computers and devices on your internal network.

    Router(config)#interface Vlan1
    
    Router(config-if)#ip address 192.168.0.1 255.255.255.0
    
    Router(config-if)# no shutdown
    
    Router(config-if)# exit
    

    Step 6 . Create Access list .

    Create acecss list for internal subnet

    Router(config)#access-list 101 permit ip 192.168.0.0 0.0.0.255 any
    

    Step 7 . NAT Configuration .

    Configure NAT

    Router(config)# ip nat inside source list 101 interface fa04 overload
    
    Router (config)# interface Fa04
    
    Router (config-if)# ip nat outside
    
    Router (config)# interface Vlan1
    
    Router (config-if)# ip nat inside
    

    Step 8 . Configure Routing .

    Configure all outgoing traffic to be forwarded to default gateway.

    Router(config)# ip route 0.0.0.0 0.0.0.0 9.10.10.1
    

    Step 8 . Pass external HTTP requests to internal WEB server.
    Our internal WEB server has IP address of 192.168.0.3 and external ISP Public IP is 9.10.10.10 so our rule will look like this.

    Router(config)#
    ip nat inside source static tcp 192.168.0.3 80 9.10.10.10 80 extendable